blsn.net
当前位置:首页 >> 请教用pip安装DjAngo==1.5的问题 >>

请教用pip安装DjAngo==1.5的问题

setup.py文件没有在当前目录下,cd到解压目录下安装, 另外安装django的方法有好几种,下载easy_install或者pip工具 easy_install django==1.5.1 pip install django==1.5.1

我用pip安装项目依赖的第三方库django、pytz、socialoth、django-celery,使用命令如下: pip install django==1.5 pytz socialoauth django-celery 运行后报错如下: Could not find a version that satisfies the requirement django==1.5 (fr...

setup.py文件没有在当前目录下,cd到解压目录下安装, 另外安装django的方法有好几种,下载easy_install或者pip工具 easy_install django==1.5.1 pip install django==1.5.1

当然可以,django支持python2和python3.直接pip install django就行。如果没安装pip,下载django文件,然后进入目录,python setup.py install也可以。

root@ubt:~# pip Traceback (most recent call last): File "/usr/bin/pip", line 9, in load_entry_point('pip==1.5.4', 'console_scripts', 'pip')() File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 351, in load_entry_poi...

linux下,应该是 sudo pip install django==1.11.8 #python2 sudo pip3 install django==1.11.8 #python3

为什么用pip install会出现Could not find a version that satisfies the requirement ×××那就尝试用easy_stall安装试一下

你说说,都有哪些坑?网上各种无效,是你的问题,不是教程问题。你至少把你测试过程中遇到的问题说出来,而不是一昧的说无效。 一般来说,linux安装软件遇到的都是依赖问题,就是安装fabric之前,必须安装依赖的东西。

首先当然是安装你需要的两个不同版本的python,这里我安装的是2.7和3.3的,两个版本安装顺序无所谓。 接下来就是检查环境变量,缺少的我们需要添加。先找到环境变量的位置。 在Path环境变量中检查以下4个变量(Path中的环境变量是以分号隔开的)...

在文件的开始写 #!usr/bin/env python3

网站首页 | 网站地图
All rights reserved Powered by www.blsn.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com